Issues with FTN
Incident Report for Scrive
Resolved
Our supplier has identified and resolved the issue from their side. In case you are still experiencing any issues related to this, get in touch with our support via support@scrive.com
Posted Nov 30, 2023 - 14:29 CET
Investigating
The external eID service FTN is currently experiencing technical difficulties.
Our external provider Nets is aware and working on resolving the issue.
Updates will follow as information is made available.
Posted Nov 30, 2023 - 12:53 CET
This incident affected: eID Hub (Finnish Trust Network (FTN)).