Support phone - Degraded performance affecting our phone

Incident Report for Scrive

Resolved

This incident has been resolved.
Posted Apr 22, 2025 - 14:00 CEST

Investigating

We are currently experiencing a degraded performance affecting our phone support. Our service provider is actively working to restore normal functionality as soon as possible. This may result in longer wait times or difficulties reaching our agents.

We’re sorry for any disruption this may cause. We’ll provide updates as soon as we have more information.

If you need assistance, please reach out to us via support@scrive.com.
Posted Apr 22, 2025 - 11:17 CEST
This incident affected: Support (Phone lines).