Third-party eID Issue: MitID

Incident Report for Scrive

Resolved

Our supplier have identified the cause of the issue and it has now been resolved. In case you are still experiencing any issues related to this, get in touch with support via support@scrive.com
Posted Jan 12, 2026 - 13:53 CET

Identified

External MitID is experiencing degraded performance.

We are monitoring the situation and will provide and update as it's resolved.
Posted Jan 12, 2026 - 10:44 CET
This incident affected: eIDs (MitID Business, MitID Private).