Email delivery - degraded performance

Incident Report for Scrive

Resolved

This incident has been resolved.
Posted Aug 18, 2026 - 08:15 CEST

Investigating

We’re currently experiencing degraded performance with our email services across our products. Our team is currently working to restore normal performance levels. We apologise for any inconvenience.

Meanwhile, a workaround is to use other delivery methods to ensure that the processes goes through smoothly.

Updates will follow in a timely manner.
Posted Aug 17, 2026 - 12:49 CEST
This incident affected: Scrive (Email delivery).