Third-party eID Issue: MitID

Incident Report for Scrive

Resolved

This incident has been resolved.
Posted Jun 10, 2025 - 09:39 CEST

Investigating

External eID MitID is experiencing degraded performance.

We are monitoring the situation and will provide and update as it's resolved.
Posted Jun 10, 2025 - 08:45 CEST
This incident affected: eIDs (MitID Business, MitID Private).