Issues with NemID and FTN
Incident Report for Scrive
Resolved
Our supplier has identified and resolved the issue on their side. In case you are still experiencing any issues related to this, get in touch with support via support@scrive.com
Posted May 31, 2023 - 14:40 CEST
Investigating
Our provider Nets is currently experiencing issues with NemID and FTN transactions.

For users experiencing issues, a possible workaround is to use alternative signing methods.

Timely updates will follow.
Posted May 31, 2023 - 11:45 CEST
This incident affected: eID Hub (Finnish Trust Network (FTN)).