Scrive eSign Office Add-in – Partial Outage

Incident Report for Scrive

Identified

We’re aware of issues with the Scrive Office Add-in not working properly in some cases.
We’re investigating the issue and working on a fix.

If you’re experiencing issues, please ask your 365 admin to uninstall the add-in and reinstall it from AppSource, making sure version 1.1.0.0 is installed.
Updates will follow once the issue is fully resolved.
Posted Jun 04, 2025 - 08:00 CEST
This incident affects: eSign Integrations (Office Add-In).