Email delivery - degraded performance

Incident Report for Scrive

Resolved

This incident has been resolved.
Posted Sep 01, 2025 - 19:34 CEST

Identified

We’re currently experiencing degraded performance with our email service. Our service provider is currently working to restore normal performance levels. We apologise for any inconvenience.

Updates will follow in a timely manner.
Posted Sep 01, 2025 - 18:31 CEST
This incident affected: Scrive (Email delivery).