Third-party eID Issue: Finnish Bank eIDs (FTN)

Incident Report for Scrive

Resolved

This incident has been resolved.
Posted Jan 15, 2026 - 16:31 CET

Identified

External Finnish Bank eIDs (FTN) is experiencing degraded performance.

We are monitoring the situation and will provide and update as it's resolved.
Posted Jan 15, 2026 - 09:58 CET
This incident affected: eIDs (Finnish Trust Network (FTN)).