Issues with Scrive GO
Incident Report for Scrive
Resolved
We have now identified the cause of the issue and applied a fix. We see no further issues - If you're still experiencing problems, please reach out to our support: support@scrive.com
Posted Mar 20, 2024 - 12:50 CET
Investigating
We have received information that we are currently experiencing issues with logging into the Scrive GO service, we are investigating this issue.

For users who are experiencing issues, a possible workaround is to login via the portal and send out documents via the eSign Online portal via https://scrive.com

Another workaround if you're able to save the PDF file locally to your computer, you can upload it to the following site:
https://go.scrive.com/public-go/direct-upload

Updates will follow in a timely manner.
Posted Mar 20, 2024 - 10:33 CET
This incident affected: eSign (GO).