Potential Issues with the Scrive eSign Retail App on iOS
Incident Report for Scrive
Resolved
The issue has now been resolved.
If you continue to experience any problems, please don't hesitate to contact Scrive Support.
Posted Nov 29, 2024 - 10:15 CET
Identified
We are aware that signing via the Scrive eSign Retail App on iOS or iPad devices may, in certain cases, lead to issues or prevent signing. Our team is actively investigating the problem and will share updates as soon as a solution is implemented.

This issue is specific to the Scrive eSign Retail App on iOS and iPad. Other browsers, apps, and device combinations are not affected.
Posted Nov 29, 2024 - 08:00 CET
This incident affected: eSign (Online).