Scrive support phone experiencing interruptions
Incident Report for Scrive
Resolved
The incident has been resolved.
Posted Aug 22, 2023 - 13:34 CEST
Monitoring
Issue is resolved and we are monitoring the results.
Posted Aug 22, 2023 - 13:21 CEST
Identified
The Scrive Support phone line is experiencing disruptions and calls might currently not connect properly.
The issue is identified and being investigated.
Posted Aug 22, 2023 - 13:12 CEST
This incident affected: Support (Phone lines).