Scrive Extended Compliance – Degraded performance

Incident Report for Scrive

Resolved

We have now identified the cause of the issue and applied a fix. We see no further issues - If you're still experiencing problems, please reach out to our support: support@scrive.com
Posted Jun 05, 2025 - 15:04 CEST

Investigating

We’re currently experiencing degraded performance in the Scrive Extended Compliance environment. Our team is currently working to restore normal performance levels. We apologise for any inconvenience. Some users may be affected.

If there are any questions, please reach out to support@scrive.com

Updates will follow in a timely manner.
Posted Jun 04, 2025 - 14:43 CEST
This incident affected: Scrive Extended Compliance (eSign Online, eSign API, Flow API, eID Hub API, eSign GO, ID-check, KSI (Guardtime), PAdES, Email Delivery, SMS Delivery, Retail eSign App, Forms Builder, Offboarding).