Scrive GO - "Print Webpage" Feature Issue
Incident Report for Scrive
Resolved
This incident has been resolved.
Posted Nov 19, 2024 - 16:04 CET
Identified
We are currently experiencing issues with the "Print Webpage" feature in the Scrive GO web extension (Chrome/Edge). Our team is actively working on a fix, and we will provide an update as soon as the issue is resolved.

Thank you for your patience and understanding.
Posted Nov 19, 2024 - 15:55 CET
This incident affected: eSign (GO).