Monitoring: AWS outage

Incident Report for Scrive

Resolved

AWS reports that their incident is over, so we will go back to normal operations.
Posted Oct 21, 2025 - 05:37 CEST

Monitoring

Amazon Web Services (AWS) is experiencing an outage in one of their US regions. While Scrive does not have any services hosted outside Europe and our services are therefore unaffected, we are monitoring the situation in case it spreads to Europe.
Posted Oct 20, 2025 - 10:39 CEST
This incident affected: Scrive (eSign Online, eSign API, eSign Flow, eID Hub API, Flow API, eSign GO, ID-check, KSI (Guardtime), PAdES, Email delivery, SMS delivery, Retail eSign App, Forms Builder, Offboarding, Contact Book) and eIDs (Finnish Trust Network (FTN), Freja eID, iDIN, itsme QES, MitID Business, MitID Private, Norwegian BankID, Onfido, Scrive QES, Smart-ID, SMS OTP, Swedish BankID, Swisscom QES, Verimi QES).