E-mail delivery – Partial Outage

Incident Report for Scrive

Update

Email delivery to Microsoft-hosted mailboxes has stabilized following earlier deferrals. Deferred messages are clearing, and delivery rates have returned to normal. We will continue to actively monitor email queues throughout the weekend to ensure ongoing stability. We will provide further updates if any new issues arise.
Posted Sep 04, 2026 - 16:56 CEST

Monitoring

We are currently tracking a global issue affecting email delivery to Microsoft-hosted mailboxes. As a result, some outgoing messages may experience temporary delivery delays. This indicates that Microsoft’s receiving servers are temporarily throttling incoming connections and requesting sending systems to retry delivery later. Our systems will automatically continue attempting delivery until the messages go through. We are actively monitoring the situation and appreciate your patience while their engineers works to resolve the issue.
We apologize for any inconvenience this may cause. Updates will follow.
Posted Sep 04, 2026 - 12:37 CEST

Investigating

We are currently experiencing delays with E-mail delivery. Our team is currently investigating the cause of the delays.
eSign users using invitation and confirmation method E-mail may be affected. We apologize for any inconvenience.

Meanwhile, a workaround is to use an alternative delivery method (SMS/Invitation method link/In-person meeting).

Updates will follow in a timely manner.
Posted Sep 04, 2026 - 10:46 CEST
This incident affects: Scrive (Email delivery).