Issues with MitID
Incident Report for Scrive
Resolved
We have received information that the issues with MitID has been resolved and operates normally again. In case you are still experiencing any issues, please get in touch with support: support@scrive.com
Posted Dec 01, 2022 - 09:34 CET
Investigating
We have received information that MitID is currently experiencing issues. These issues may affect MitID transaction in documents and our eID-hub. We are monitoring for updates from MitID and will update this post when new information is available.
Posted Dec 01, 2022 - 09:03 CET
This incident affected: eID Hub (MitID).