Signing with the Retail eSign application not working
Incident Report for Scrive
Resolved
The issue has been resolved by rolling back to an earlier version.

In case you are still experiencing issues, please get in touch with our support team: support@scrive.com
Posted May 22, 2023 - 22:03 CEST
Investigating
Documents sent out to be signed via the Retail eSign app can not be signed at the moment due to an unknown issue. We are investigating and updates will be sent accordingly.
Posted May 22, 2023 - 19:58 CEST
This incident affected: eSign (Online).